當我在macOS sierra中要安裝R package時(source package),安裝失敗,錯誤訊息顯示如下:

gfortran-4.8: warning: couldn’t understand kern.osversion ’16.0.0

搜尋了一下,解法如下:

1. 安裝XCode Tools

     xcode-select --install

2. 下載並安裝gnu gfortran  http://hpc.sourceforge.net/

     gfortran-6.2-bin.tar.gz 
      sudo tar -xvf gfortran-6.2-bin.tar.gz -C /

3. 設定R使用gfortran

     mkdir ~/.R

     在~/.R目錄內新增Makevars檔,內容為:

          F77 = gfortran
          FLIBS =  -L/usr/local/lib/gcc/x86_64-apple-darwin15.6.0/6.2.0 -lgfortran -lquadmath -lm

就可以了! 

參考資料:

https://stat.ethz.ch/pipermail/r-sig-mac/2016-February/011825.html

https://cran.r-project.org/doc/manuals/R-admin.html#Customizing-package-compilation

 

文章標籤

創作者介紹
創作者 Person 的頭像
Person

Person的網路日誌

Person 發表在 痞客邦 留言(0) 人氣()